Problem
The collective run - report / RTC / R_LIB_LAT_COLLECT - does not update the IQ LIB data on the SmartChange controller.
Root Cause
Various causes can prevent IQ LIB data from being updated. The following causes are known:
The collective run is canceled with the runtime error TSV_TNEW_PAGE_ALLOC_FAILED.
The collective run is aborted with the runtime error DBSQL_DUPLICATE_KEY_ERROR.
The collective run is canceled because the transfer of the data to the SmartChangeController was terminated with a timeout
Restart the SmartChange controller
The collective run runs endlessly and the same transport request is always read
After a system copy, IQ LIB data are no longer updated
Solution:
The following points must be checked:
Timeout & Terminations
During the initial run, it is advisable to temporarily increase the profile parameter rdisp / max_wprun_tim (Maximum work process run tim) in the SmartChange Controller to 9200.
Check the set packet size in the SmartChange Controller
Change the package size for the IQ LIB collective runFor point 2 there is a program correction KB entry rtcSup-KB-20160329-7003 for SC2014 SP2
For point 4 there is a program correction KB entry rtcSup-KB-20160329-6899 for SC2015 SP1 and SC2014 SP4
Reboot & System copies
Call transaction SM12 for lock entries in the SmartChange Controller.