Why are IQ LIB data not updated?

Problem

The collective run - report / RTC / R_LIB_LAT_COLLECT - does not update the IQ LIB data on the SmartChange controller.

Root Cause

Various causes can prevent IQ LIB data from being updated. The following causes are known:

  1. The collective run is canceled with the runtime error TSV_TNEW_PAGE_ALLOC_FAILED.

  2. The collective run is aborted with the runtime error DBSQL_DUPLICATE_KEY_ERROR.

  3. The collective run is canceled because the transfer of the data to the SmartChangeController was terminated with a timeout

  4. Restart the SmartChange controller

  5. The collective run runs endlessly and the same transport request is always read

  6. After a system copy, IQ LIB data are no longer updated

Solution

The following points must be checked:

Timeout & Terminations

  1. During the initial run, it is advisable to temporarily increase the profile parameter rdisp / max_wprun_tim (Maximum work process run tim) in the SmartChange Controller to 9200.

  2. Check the set packet size in the SmartChange Controller
    Change the package size for the IQ LIB collective run

  3. For point 2 there is a program correction KB entry rtcSup-KB-20160329-7003 for SC2014 SP2

  4. For point 4 there is a program correction KB entry rtcSup-KB-20160329-6899 for SC2015 SP1 and SC2014 SP4

Reboot & System copies

  1. Call transaction SM12 for lock entries in the SmartChange Controller.

2. Delete the lock entry for lock object / RTC / LIB_D_OBJ.

3. After a system copy, the data already collected in the SmartChange Controller are no longer correct. These have to be corrected again.