What does the return code 1234 mean?

Problem

When importing transports via Transport Management, return codes with the value 1234 are generated.

 

Cause

The return code 1234 is an "artificially" generated return code by Transport Management. This can occur under the following circumstances:

  1. The import was canceled from the queue management and the corresponding stop entry could not be completely removed.

  2. Transport files are not located in the transport directory of the importing system.

  3. Transport files (especially the control file) do not have the appropriate (read and write) authorization on the importing system.

  4. After a system copy has been carried out.

 

Solution

to 1.

Check on the importing system whether an import is currently in progress. If no import is running on the importing system, the entry in the / RTC / TM_STOP table can be removed. You can then check in the queue management whether the "Abort import" indicator (stop sign) is still displayed. This should no longer be the case after the table entry has been deleted.

to 2 .

Check whether the transport files exist in the transport directory of the importing system.

to 3.

Check whether the (read and write) permissions at operating system level are available for the transport files on the importing system.

to 4 .

Check whether an "obsolete" (with incorrect parameters) executed import job is still scheduled on the target system of the system copy. You can recognize this by the name. Import jobs automatically scheduled via the scheduler follow the rule <SID_TM> <SID_Zielsystem> @@ <transport level, for example DEVQAS @@ Quality. Delete the obsolete jobs. If you are not sure, you can also delete all scheduled "@@" jobs on the target system and then reschedule them again using the scheduler.